Disponibilité du magazine en kiosques

Suite à la faillite de plusieurs sociétés de distribution de presse (journaux et magazines), conséquence de la liquidation judiciaire de Presstalis, des centaines de kiosques et points de vente de presse ne reçoivent plus du tout, ou très partiellement, de magazines, dont Programmez!.

En attendant que la situation puisse revenir à la normale, la meilleure solution est l’abonnement.

Sortie de WordPress 5.2 'Jaco'

Par:
fredericmazue

ven, 10/05/2019 - 17:33

Le célèbre CMS WordPress vient de sortir en version 5.2. Il s'agit d'une importante version qui apporte 62 améliorations ou nouvelles fonctionnalités et qui corrige 228 bugs. Mais c'est surtout par une évolution de Site health Check que cette mouture se fait remarquer.

Site Health Check est un projet visant à améliorer la stabilité et les performances de l’ensemble de l’écosystème WordPress. Déjà Site Health Check vérifie si un plugin nécessite une version de PHP incompatible avec votre site. Si c'est le cas, l'installation ce plugin sera impossible. Avec WordPress 5.2, Site Health Check vous protège des écrans blancs de la mort (WSOD pour White Screen Of the Death) qui jusqu'ici apparaissaient en cas d'erreur fatale PHP.

Même dans le cas où une erreur fatale aurait rendu le backend complètement inaccessible sous une version précédente, les administrateurs auront toujours la possibilité de se connecter et de faire quelque chose pour corriger le problème.

Lorsqu'une erreur irrécupérable se produit, un écran d'erreur destiné à l'utilisateur s'affiche pour informer l'utilisateur / visiteur que le site rencontre des difficultés techniques. En outre, un courrier électronique sera envoyé à l'adresse électronique de l'administrateur, l'informant du problème et incluant un lien secret vers une nouvelle fonctionnalité appelée «mode de récupération». En cliquant sur ce lien, l'utilisateur entre dans ce mode de récupération.

En mode de récupération, les plug-ins et les thèmes qui provoquent une erreur fatale sont suspendus pour ce client, ce qui permet de contourner les erreurs et d’accéder au backoffice. 

Il est à remarquer que l'équipe de développement de WordPress fait la chasse aux versions de PHP obsolètes. Avec WordPress 5.2, les versions de PHP inférieures à 5.6.20 ne sont pas acceptées. Autrement dit la mise à jour de votre CMS vers sa version 5.2 sera impossible dans un tel cas.