Ajouter un commentaire

fred1599

Quote:
Faudrait voir le contenu de ce fichier aux alentours de la ligne 485. Peut être y-t-il une déclaration dans un vieux style dont le compilateur ne veut plus.
Si c'est le cas, il faudra modifier dsputil.h pour que ce compile, ou soumettre le problème aux développeurs du trucs. Si ça se trouve c'est une FAQ ça.

En fait ce n'est pas un problème au niveau de ce fichier, je suis parti me reposer un peu en week et m'y suis remis.

J'ai trouvé la solution, elle est LA

Quote:
I just tried to build pymedia on my Ubuntu system with gcc4.2 & python2.5 and encountered the same error.

I made one change and have successfully compiled, installed and imported pymedia (I haven't used it yet, but I don't expect this change to affect that).

In on line 31 insert the following:

Code:
#define HAVE_LRINTF

So you should have:

Code:
#include
#define HAVE_LRINTF
#include "libavcodec/dsputil.h"
#include "version.h"

Note that it must be before including

Merci, tu m'as donné la puce à l'oreille :wink:

A bienôt :D

Filtered HTML

Plain text

CAPTCHA
Cette question permet de vérifier que vous n'êtes pas un robot spammeur :-)
 L     EEEE  N   N  V     V  L    
L E NN N V V L
L EEE N N N V V L
L E N NN V V L
LLLL EEEE N N V LLLL