Ajouter un commentaire

Apple Silicon M1 : une question de Terminal

Par:
ftonic

jeu, 22/04/2021 - 11:13

Si vous utilisez un Mac à processeur M1 (Apple Silicon) pour vos développements, vous savez sans doute que les galères d'installation et d'exécution arrivent très vite surtout quand on commence à utiliser des outils comme Jekyll, Hugo, Flutter, etc. 

En Terminal, on trouve, encore trop souvent, des erreurs d'installation, faute d'une version compatible M1. Pour résoudre une partie du problème, il faut forcer l'utilisation de Rosetta 2 (la couche compatibilité x86). Ainsi, pour le Terminal, cochez l'option Rosetta dans la fenêtre d'information. D'autre part, pour contourner certaines erreurs, utilisez systématiquement la commande sudo. 

Dans notre cas, nous avons pu installer jekyll sans difficulté et exécuter les sites statiques (utilisation systématique de sudo pour la commande bundle exec jekyll serve et en création avec la commande new).

Espérons que les portages sur Apple Silicon se généraliseront rapidement.

François Tonic

Filtered HTML

Plain text

CAPTCHA
Cette question permet de vérifier que vous n'êtes pas un robot spammeur :-)
 PPPP    GGG    AA   TTTTTT  V     V 
P P G A A TT V V
PPPP G GG AAAA TT V V
P G G A A TT V V
P GGG A A TT V