E clipse 3.3 + PDT: des gens ont testé?

nivren
E clipse 3.3 + PDT: des gens ont testé?

Voilà, je me suis dit quitte a développer proprement, autant utiliser de vrais outils....
J'ai telechargé le bundle eclipse +pdt de zend (http://www.zend.com/pdt/)
pour me rendre compte que.... Chez moi, ca ne amrche pas. Le plug in est noté comme actif, mais je ne le vois ni dans l'onglet perspective ni dans l'onglet configuration.
Je sèche.... Des Idées?

fredericmazue

Je ne connais pas. Mais si c'est dans la philosophie d'autres plugins peut être faut-il d'abord créer un "projet php" et tu auras accès à la perspective ensuite.

nivren

Je me suis posé la question....
Je vois d'ailleurs que vous en parlez dans la news d'hier.
Je suis partant pour utiliser des outils "récents"... Mais la je trouve que niveau doc, c'est très light.
J'ai essayé de créer un projet "php" mais je n'ai meme pas ce choix la. J'en parlais a un ami chez qui ca marche sans soucis. Nous sommes tous les deux sous xp pro. J'avoue que la je sèche....

fredericmazue
Je suis partant pour utiliser des outils "récents"...
Et moi pour éviter tous problèmes, je suis partant pour l'utilisation d'Emacs :)
J'avoue que la je sèche....
J'avoue que je ne sais pas. Quand j'aurais un moment, je vais installer tout ça et regarder, par curiosité. Mais faut que j'ai le temps. Peut être quelqu'un d'autre aura-t-il la réponse.
nivren

Bah disons qu'a l'epoque j'utilisais la bonne vieille 3.1 d'clipse avec phpeclipse et que ca marchait pas trop mal.
Mais la nouveau projet, je me suis mis a symfony etc. Du coup je me suis dit on va frapper fort.
Bah ouais.
C'est surtout ma tete qui frappe fort contre les murs.
15 installes hier soir. Meme combat.
Mon pote me nargue avec son installe unique qui marche du feu de dieu.
Je crois que bientot je vais avoir un moulage mural a mon effigie.

bast2

J'ai prévu de le tester dans la semaine. Je te dirais si j'ai été confronté à ton problème.

nivren

bon je vais rester suspendu a tes levres alors.
Je vais installer sur mes deux autres pc la meme version voir ce qui se passe.
Je serais quand meme embeté de devoir développer sur mon vieux athlon 1600+ tout simplement parce qu'il n'y a que sur cette machine que ca fonctionne :(

fredericmazue
Je serais quand meme embeté de devoir développer sur mon vieux athlon 1600+ tout simplement parce qu'il n'y a que sur cette machine que ca fonctionne
A priori, il n'y a pas de raison que cela soit lié à la bécane.
nivren

Non je ne pense pas.... Mais j'ai une autre version d'OS dessus. Je tourne encore sous 2000.

Ca peut etre de toute facon qu'une question d'environnement ou de logiciels présents ou d'OS.
Le probleme c'est qu'a la différence d'unix ou je maitrise bien tous les éléments, sous windows j'ai l'impression de me noyer dans uen goutte d'eau. Et en plus de cela, impossible de trouver les logs de démarrage d'eclipse pour le moment. Il doit bien y en avoir :(

fredericmazue
Je tourne encore sous 2000.
Je ne pense pas non plus que ça soit un problème.
Le probleme c'est qu'a la différence d'unix ou je maitrise bien tous les éléments, sous windows j'ai l'impression de me noyer dans uen goutte d'eau.
Ah ça. .. je te comprends. Bill Gates, on dirait Jean Levfèvre dans "On a retrouvé la 7eme compagnie" .... "Touche pas à ça p'tit con" :lol:

Bref, sous Windows les choses ne sont pas toujours très claires. (euphémisme)

Et en plus de cela, impossible de trouver les logs de démarrage d'eclipse pour le moment. Il doit bien y en avoir
Il y a. Sous Windows si je ne m'abuse, ils sont dans le répertoire d'Eclipse lui même, quelque part.... Enfin c'était comme ça avec un 3.1. Je ne me souviens pas parfaitement. J'utilise rarement Eclipse. Je trouve Emacs bien supérieur. Non non sans blague :D Là je suis en train d'installer mille trucs sur un Vista tout neuf, tout en bossant sur une autre bécane. :P Quand j'en serai à mettre un Eclipse, je ne manquerait pas de regarder comment ça roule.
nivren

Tu vas pas t'ennuyer ^^
Eclipse y'a de quoi faire. Moi qui dev pas mal en php, les tests unitaires et tout ca j'ai beaucoup apprécié. Après phpeclipse était encore limité (débugging non natif)
Maintenant en théorie, le debbugging est inclus dans eclipse avec le pdt. Pour tout dev objet, c'est le bonheur.
Faut que j'essaie de trouver les logs et les pseudos pré requis eclipse... Il doit me manquer un truc :( je ne rencontre qu'une personne qui a eu le probleme, mon moral en prends un coup.

fredericmazue

bad news,

J'ai essayé, mais je jette l'éponge devant le nombre de plugins dépendants à télécharger. J'ai craqué avec GEF car je n'ai trouvé nul par le lien à donner à l'update manager. :(

Plus tard peut être quand j'aurai plus de temps. (beaucoup d'autres choses à installer sur mon Vista)

Mon Emacs va bien par contre :)

nivren

je vais te simplifier la vie: tu as une distrib all-in-one dispo ici:
http://www.zend.com/pdt/

tu prends celle du 17.

Tu as juste a DEZIPPER, tout est déja inclus dedans, et a démarrer eclipse.

fredericmazue
tu as une distrib all-in-one dispo ici
Merci :) Je vais regarder ça. Par contre je ne vais pas dézipper comme tu dis. Mais installer via l'update manager et le web. Je fais toujours comme ça. Pour m'y retrouver plus tard :)
nivren

j'y suis pas arrivé a cause des dépendance. Mais si tu y parviens ;)
Moi j'ai pris la all-in-one qui fonctionne chez ems amis.
Sauf chez moi :cry:

fredericmazue
Sauf chez moi
Ben peut être que tu as un problème de dépendances justement. Ce que je veux à tout prix éviter en "dézippant" ceci puis un jour cela.... :(
fredericmazue

Alors j'ai essayé le "tout-en-un" et ça marche convenablement semble-t-il.
En créant un projet Php on accède à la perspective Php et tout le reste semble aller à la suite.

J'ai importé ce tout-en-un avec l'update manager en configurant un site local. Je n'ai pas "dézippé" brutalement dans le répertoire d'Eclipse.
Si tu as dézippé directement, peut être as tu quelque chose qui cloche dans ton Eclipse, je ne sais pas.

nivren

j'ai resolu mon probleme.......

En rebootant mon pc :?

ok.... je sors :arrow:
bon reste maintenant a tester toutes les fonctionnalités qu'il y a derriere.
Ca va etre la partie delicate...

fredericmazue
j'ai resolu mon probleme....... En rebootant mon pc
Dans le contexte de Java et d'Eclipse, je vois mal le rapport :shock:

Enfin... le principal c'est que ça marche :)