[PHP] pb de connexion a mysql en local

romagny13 Portrait de romagny13
[PHP] pb de connexion a mysql en local

bonjour

1 - jai installé wamp (dans sa derniere version 1.6.3) pour pouvoir tester localement mon site que je vais mettre en ligne prochainement avec lycos multimania

jai un probleme , je narrive pas a me connecté a ma base mysql (sur mon ordinateur)
(javais essayer egalement dinstaller easy php 8) et ca faisait la mm chose exactement donc est que cela pourrait venir dun reglage sur mon pc(parametres de securite,firewall,par ex) quil faudrait regler ...bref

en effet jai ce message d'erreur qui saffiche dans le navigateur internet explorer>>

Warning: mysql_connect() [function.mysql-connect]: Unknown MySQL server host 'romagny13_db' (11001) in C:\wamp\www\MULTIMANIA_3\outil.php on line 292 la connection a echoue

et ce message d'erreur lorsque je debugge dans php edit v0.6
Error:
Access denied for user 'ODBC'@'localhost'(using password:NO) at c:\wamp\www\MULTIMANIA_3\outil.php line 288

voici ma chaine de connexion (si ca peut vous etre utile car je doute que cela provienne delle le pb...,multimania est le nom que jai donne a ma base de donnée...)
$nombase="multimania";
$id_connex=mysql_connect("localhost","romagny13","") or die("la connection a echoue");
mysql_select_db($nombase,$id_connex);

2 - de plus pourriez vous maider a configurer PHP EXPERT EDITOR (version 3.3 ou 4.0)
pour pouvoir debugger le php loacalement ?
(il me semble qu'il y a une dll (PHP_dbg.dll ??) quil faut copier quelque part , et je ne sais pas ou aller la chercher enfin vvous voyez quoi je sais po loll

3 - est il possible de debugger directement son projet PHP/mysql situé chez hebergeur ?

merci bocou a tous ceux qui voudront bien prendre quelques minutes pour me repondre (je suis pas fortiche en php) et a charge de revanche

A++ :D

bast2

Je reprend point par point tes questions:

1. Pour ton problème de connexion peux tu confirmer qu'aucun mot de passe n'a été définit à la création de ta base de données ? et que le login que tu as attribué est bien romagny13. Essayes de remplacer romagny13 par root (qui est souvent le login par défaut), et si cela ne fonctionne toujours pas de définir un mot de passe sur ta base de données, et de l'inscrire dans ton fichier de connexion.

Autre point à vérifier: quand tu saisis localhost dans ton navigateur, est ce que tu accèdes bien aux pages crées ?

2. Je n'utilise pas PHP EXPERT EDITOR, mais vais l'installer pour tester si personne n'a la solution.

3. qu'entend tu par debugger directement ton projet situé chez l'hébergeur ? Tu veux savoir si tu peux directement modifier les fichiers php sans avoir à modifier en local puis uploader sur le serveur ?

jrebillat

Je ne vais pas t'aider beaucoup, car j'ai banni Windows de mon PC depuis longtemps... :wink:

Mais pour le point 3), ça doit être plus ou moins faisable avec Eclipse en créant un projet dans un chemin FTP, non ?

romagny13 Portrait de romagny13

a yé j'ai résolu mon pb de connexion...

par contre j'ai essayer PHP edit version 2 et franchement il "dépote",je mets le lien ...on peut rever en imaginant ce qu'il sera d'ici quelques temps
http://www.waterproof.com/

autrement pour le 3,je voulais dire :
est il possible de debugger(pas a pas avec points arrets) un fichier php qui utilise une connexion a la base de donnée chez hebergeur ?

merci pour vos réponses A++

Google est ton ami, MSDN et la communauté aussi .

jrebillat
est il possible de debugger(pas a pas avec points arrets) un fichier php qui utilise une connexion a la base de donnée chez hebergeur ?

Ca dépend de la configuration de l'hébergeur. Mais ceux chez qui j'ai des sites - donc des bases - ont tous bloqué l'accès MySQL à distance, limitant l'accès à "localhost".

bast2
a yé j'ai résolu mon pb de connexion...

Peux-tu préciser comment tu as résolu ton problème de connexion à la base ? Cela pourrait aider d'autres personnes qui pourraient rencontrer le même problème que toi.

romagny13 Portrait de romagny13

oui,
déja jai installé la version wamp5 1.4.3 avec laquelle javais deja develope dans le passé et qui ne me posait pas de pb de connexion puis
jai utilisé la commande GRANT pour m'attribuer tous les priviléges

...

oui tout a fait chez lycos multimania on est aussi en localhost donc pas de debuggage en vu possible
++

Google est ton ami, MSDN et la communauté aussi .